Jump to content
loque76

HSBC Visa Debit Card - Bad Batch???

style="text-align:center;"> Please note that this topic has not had any new posts for the last 3654 days.

If you are trying to post a different story then you should start your own new thread. Posting on this thread is likely to mean that you won't get the help and advice that you need.

If you are trying to post information which is relevant to the story in this thread then please flag it up to the site team and they will allow you to post.

Thank you

Recommended Posts

Hi all, I'm new to these forums.

 

Just posting a quick question out there to everyone regarding my Visa card from HSBC and curious if anyone else is having the same issue?

 

In the past month or so my card has stopped working 3 times and I have had to have new ones sent to me each time. Now this is very annoying considering that for the '5 working days' it takes them to send me a new one I have to rely on friends for cash.

 

I have spoken to HSBC minutes after each card has failed to work in order to ensure that there has been no fraud etc and each time I am informed that "the machine has registered the card with HSBC but failed to read it".

 

Every time the cards have no apparent damage visible on them. I have also tried to approach it from a technical point of view and try to assure that my cards do not go near anything magnetic etc.

 

Is this a common occurrence amongst anyone else???

 

Any recommendations???

 

Cheers

 

-Chris-

Share this post


Link to post
Share on other sites

What fails? Chip? Mag Stripe? What message is shown when the card is used 'Blocked' 'Invalid' or what?

Share this post


Link to post
Share on other sites

Have you tried a different ATM?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 Caggers

    No registered users viewing this page.


  • Have we helped you ...?


×
×
  • Create New...